Willkommen, Gast
Angemeldet bleiben:

THEMA:

PHP 8.0 und Phoca Gallery ist nicht kompatibel 30 Okt 2021 11:06 #49841

guten Tag allerseits

also eine Info meinerseits für alle die mit Phoca Gallery arbeiten, nicht auf die PHP 8.0 wechseln, mit 7.4 weiterarbeiten.

ich habe im Internet recherchiert, keiner konnte mir helfen. Jetzt nachdem ich festgestellt habe, dass nirgends mehr Bilder zu sehen waren  habe ich von 8.0 auf 7.4 zurückgestellt. 

Alles läuft wie vorher

Gruss Andreas

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

PHP 8.0 und Phoca Gallery ist nicht kompatibel 30 Okt 2021 14:51 #49842

Hi,
welche Version der Phoca Gallery Komponente verwendest Du denn und wie zeigst Du Deine Bilder an, mit der Komponente oder mit dem Plugin innerhalb Artikeln?
Hintergrund meiner Frage ist, dass das Problem seit der Version 4.4.1 vom 08.02.2021 (die aktuelle Version ist 4.4.3) nicht mehr bestehen sollte:
www.phoca.cz/news/1120-phoca-gallery-version-4-4-1-released

Changelog:

  • Ready for Joomla! 3.9.24
  • Ready for PHP 8.0.1

Freundliche Grüße,
Benno
 

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

PHP 8.0 und Phoca Gallery ist nicht kompatibel 30 Okt 2021 15:11 #49843

mit 4.4.3 so wie ich es sehe mit dem Plugin oder ja so wie das Bild es zeigt , und joomla 3.10.3, wobei ich die PHP ebenfalls noch von 7.4. auf 8.0 stellte. dieser Wechsel von 7.4. auf 8.0 war schlecht, damit hatte Phoca dafür gesorgt, dass keine Bilder mehr angezeigt wurde. nur wieso weiss ich nicht. ich stellte einzig die PHP zurück auf 7.4 und alles lief wieder

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

PHP 8.0 und Phoca Gallery ist nicht kompatibel 31 Okt 2021 09:04 #49844

Hi,

nur wieso weiss ich nicht

Deshalb wäre es gut Fehlermeldungen zu erhalten, von der JS-Konsole, oder per Error Reporting=Development, oder per Debug System (Call Stack).
Damit könnte Jan, der Entwickler aller Phoca Erweiterungen, dann auf die Suche gehen.

Freundliche Grüße,
Benno
 

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

PHP 8.0 und Phoca Gallery ist nicht kompatibel 31 Okt 2021 11:42 #49845

ich habe extra wieder auf 8.0 gestellt und einen Printscreen gemacht
Anhänge:

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

PHP 8.0 und Phoca Gallery ist nicht kompatibel 01 Nov 2021 09:32 #49849

Hi,
ich hatte in der Zwischenzeit Kontakt mit Jan bezüglich Deines Problems. Folgendes hat er geschrieben:

Hallo, danke für die Info, frag ihn nach Einschalten von 'Debug Mode', da sich in dieser Fehlermeldungen dann auch:

- Die Datei, wo das Problem ist,
- Die Zeile, wo das Problem ist,
- Und Trace

darstellen. Um zu wissen, wo das Problem ist, brauchen wir mindestens die Zeilennummer und den Namen der Datei.

Danke, Jan

Freundliche Grüße,
Benno
 

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

PHP 8.0 und Phoca Gallery ist nicht kompatibel 14 Nov 2021 14:33 #49861

ich kenne mich damit nicht aus, weiss auch nicht wo suchen, sonst wäre schon lange eine Antwort von mir hier gelandet

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

PHP 8.0 und Phoca Gallery ist nicht kompatibel 14 Nov 2021 15:28 #49862

Hi,
1.) Schalte wieder auf PHP 8.0 um.
2.) Gehe zu: Backend --> System --> Konfiguration --> System --> Fehlersuche (Debug) -->
und setze: System debuggen=Ja
3.) Gehe zu Deinem Frontend und öffne Phoca Gallery.
Du wirst dann wieder den roten Kasten erhalten, aber darunter sollte eine Tabelle "Call Stack" zu finden sein.
Davon poste bitte einen Screenshot.
Danach setzt Du erstmal alles wieder zurück. (PHP auf 7.4 und System debuggen=Nein)

Freundliche Grüße,
Benno
Folgende Benutzer bedankten sich: Andreas24

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

PHP 8.0 und Phoca Gallery ist nicht kompatibel 15 Nov 2021 17:47 #49864

Danke also auf der 1. Seite habe ich nichts gefunden. mit der 2. dann schon wie der Screenshot zeigt
ich kann dort 2 verschiedene PHP schalten entweder PHP Fast CGI oder PHP FPM . ich habe bis jetzt immer Fast CGI genommen.

Screenshot anbei

so sieht es aus.
Anhänge:

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

PHP 8.0 und Phoca Gallery ist nicht kompatibel 16 Nov 2021 23:04 #49867

Hi,
zu Deinem Screenshot schrieb mir Jan folgendes:

Versuch mal diese Datei mit der Originaldatei aus dem ZIP-Package zu überschreiben (components\com_phocagallery\models\category.php)

Falls das keinen Erfolg hat, hast Du viellicht irgendeine STRICT Umgebung.

Dann versuch mal die Zeile 41 der obigen Datei so zu verändern:

VON:
$this->setState('limitstart', ($this->getState('limit') != 0 ? (floor($this->getState('limitstart') / $this->getState('limit')) * $this->getState('limit')) : 0));

ZU:
$this->setState('limitstart', ((int)$this->getState('limit') != 0 ? (floor((int)$this->getState('limitstart') / (int)$this->getState('limit')) * (int)$this->getState('limit')) : 0));

Dann sollen alle Werte Integer sein und es soll nicht zu so einem Fehler kommen.

Jan

Freundliche Grüße,
Benno
Folgende Benutzer bedankten sich: Andreas24

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Seite:
  • 1
  • 2